aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/patches-5.4/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-5.4/011-tune_lzma_options.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
index 09d3c6c7ce..de9d4421a6 100644
--- a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
+++ b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
@@ -1,14 +1,14 @@
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -342,7 +342,7 @@ quiet_cmd_bzip2 = BZIP2 $@
+ # ---------------------------------------------------------------------------
quiet_cmd_lzma = LZMA $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
-- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
- (rm -f $@ ; false)
+- cmd_lzma = { cat $(real-prereqs) | lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
++ cmd_lzma = { cat $(real-prereqs) | lzma e -lc8 -eos -si -so; $(size_append); } > $@
quiet_cmd_lzo = LZO $@
+ cmd_lzo = { cat $(real-prereqs) | lzop -9; $(size_append); } > $@
--- a/arch/x86/include/asm/boot.h
+++ b/arch/x86/include/asm/boot.h
@@ -24,7 +24,7 @@