aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 7826dc8acd..70a64ffdb4 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -280,3 +280,35 @@ define KernelPackage/i2c-scx200-acb/description
endef
$(eval $(call KernelPackage,i2c-scx200-acb))
+
+
+define KernelPackage/leds-wrap
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=PCengines WRAP LED support
+ DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+ KCONFIG:=CONFIG_LEDS_WRAP
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
+ AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
+define KernelPackage/leds-net48xx
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Soekris Net48xx LED support
+ DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+ KCONFIG:=CONFIG_LEDS_NET48XX
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
+ AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
+endef
+
+define KernelPackage/leds-net48xx/description
+ Kernel module for Soekris Net48xx LEDs
+endef
+
+$(eval $(call KernelPackage,leds-net48xx))