aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:57 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:57 +0000
commitc3b9a987b7120dbd97e095d08c7a957e5f0b5dab (patch)
tree180e4281f30e6d0bff5ace69cb2ad5310f00991f /target/linux/x86/modules.mk
parentbca45d6d8afe8eb82d36c2b50940a2e0c8cc33e9 (diff)
downloadupstream-c3b9a987b7120dbd97e095d08c7a957e5f0b5dab.tar.gz
upstream-c3b9a987b7120dbd97e095d08c7a957e5f0b5dab.tar.bz2
upstream-c3b9a987b7120dbd97e095d08c7a957e5f0b5dab.zip
move leds modules back to target modules.mk
SVN-Revision: 32851
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 7826dc8acd..70a64ffdb4 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -280,3 +280,35 @@ define KernelPackage/i2c-scx200-acb/description
endef
$(eval $(call KernelPackage,i2c-scx200-acb))
+
+
+define KernelPackage/leds-wrap
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=PCengines WRAP LED support
+ DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+ KCONFIG:=CONFIG_LEDS_WRAP
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
+ AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
+define KernelPackage/leds-net48xx
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Soekris Net48xx LED support
+ DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+ KCONFIG:=CONFIG_LEDS_NET48XX
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
+ AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
+endef
+
+define KernelPackage/leds-net48xx/description
+ Kernel module for Soekris Net48xx LEDs
+endef
+
+$(eval $(call KernelPackage,leds-net48xx))