aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 96a66b2398..efeac698b1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1167,6 +1167,20 @@ define Device/samknows_whitebox-v8
endef
TARGET_DEVICES += samknows_whitebox-v8
+define Device/sercomm_na502
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 20480k
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ UBINIZE_OPTS := -E 5
+ KERNEL_SIZE := 4096k
+ DEVICE_VENDOR := SERCOMM
+ DEVICE_MODEL := NA502
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-mt7603 kmod-usb3
+endef
+TARGET_DEVICES += sercomm_na502
+
define Device/storylink_sap-g3200u3
$(Device/dsa-migration)
IMAGE_SIZE := 7872k