aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAndreas Böhler <dev@aboehler.at>2021-03-15 00:07:17 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-06 21:00:09 +0200
commita3d8c1295ed9eeceabd78ab86e73b151ae2868a9 (patch)
tree1b704fdc8ae2a11a4cffb7f3d7817d788e7364bb /target/linux/ramips/image/mt7621.mk
parent2341c621e42e5fadd6b3205365fb448e44bcbbe0 (diff)
downloadupstream-a3d8c1295ed9eeceabd78ab86e73b151ae2868a9.tar.gz
upstream-a3d8c1295ed9eeceabd78ab86e73b151ae2868a9.tar.bz2
upstream-a3d8c1295ed9eeceabd78ab86e73b151ae2868a9.zip
ramips: Add support for SERCOMM NA502
The SERCOMM NA502 is a smart home gateway manufactured by SERCOMM and sold under different brands (among others, A1 Telekom Austria SmartHome Gateway). It has multi-protocol radio support in addition to LAN and WiFi. Note: BLE is currently unsupported. Specifications -------------- - MT7621ST 880MHz, Single-Core, Dual-Thread - MT7603EN 2.4GHz WiFi - MT7662EN 5GHz WiFi + BLE - 128MiB NAND - 256MiB DDR3 RAM - SD3503 ZWave Controller - EM357 Zigbee Coordinator MAC address assignment ---------------------- LAN MAC is read from the config partition, WiFi 2.4GHz is LAN+2 and matches the OEM firmware. WiFi 5GHz with LAN+1 is an educated guess since the OEM firmware does not enable 5GHz WiFi. Installation ------------ Attach serial console, then boot the initramfs image via TFTP. Once inside OpenWrt, run sysupgrade -n with the sysupgrade file. Attention: The device has a dual-firmware design. We overwrite kernel2, since kernel1 contains an automatic recovery image. If you get NAND ECC errors and are stuck with bad eraseblocks, try to erase the mtd partition first with mtd unlock ubi mtd erase ubi This should only be needed once. Signed-off-by: Andreas Böhler <dev@aboehler.at> [use kiB for IMAGE_SIZE] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 96a66b2398..efeac698b1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1167,6 +1167,20 @@ define Device/samknows_whitebox-v8
endef
TARGET_DEVICES += samknows_whitebox-v8
+define Device/sercomm_na502
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 20480k
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ UBINIZE_OPTS := -E 5
+ KERNEL_SIZE := 4096k
+ DEVICE_VENDOR := SERCOMM
+ DEVICE_MODEL := NA502
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-mt7603 kmod-usb3
+endef
+TARGET_DEVICES += sercomm_na502
+
define Device/storylink_sap-g3200u3
$(Device/dsa-migration)
IMAGE_SIZE := 7872k