aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index ad7c4b94d2..80bfec5ad9 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -193,6 +193,20 @@ define Device/nec_wg2600hp
endef
TARGET_DEVICES += nec_wg2600hp
+define Device/nec_wg2600hp3
+ $(call Device/LegacyImage)
+ DEVICE_VENDOR := NEC Platforms
+ DEVICE_MODEL := Aterm WG2600HP3
+ SOC := qcom-ipq8062
+ BLOCKSIZE := 64k
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := -kmod-ata-ahci -kmod-ata-ahci-platform -kmod-usb-ohci -kmod-usb2 \
+ -kmod-usb-ledtrig-usbport -kmod-usb-phy-qcom-dwc3 -kmod-usb3 -kmod-usb-dwc3-qcom \
+ ath10k-firmware-qca9984-ct ipq-wifi-nec_wg2600hp3
+endef
+TARGET_DEVICES += nec_wg2600hp3
+
define Device/netgear_d7800
$(call Device/DniImage)
DEVICE_VENDOR := NETGEAR