aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch')
-rw-r--r--target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch b/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
new file mode 100644
index 0000000000..e176bf5366
--- /dev/null
+++ b/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
@@ -0,0 +1,21 @@
+--- a/crypto/Config.in
++++ b/crypto/Config.in
+@@ -117,4 +117,6 @@ if [ "$CONFIG_CRYPTO" = "y" ]; then
+ tristate ' Testing module' CONFIG_CRYPTO_TEST
+ fi
+
++source crypto/ocf/Config.in
++
+ endmenu
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -36,4 +36,9 @@ obj-$(CONFIG_CRYPTO_MICHAEL_MIC) += mich
+
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
++mod-subdirs += ocf
++subdir-$(CONFIG_OCF_OCF) += ocf
++ocf-$(CONFIG_OCF_OCF) = ocf/ocfdrv.o
++obj-$(CONFIG_OCF_OCF) += $(ocf-y)
++
+ include $(TOPDIR)/Rules.make