aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:00:14 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:00:14 +0000
commit0ff83e90ba5f0ed1d900813b470f61527500fdd8 (patch)
tree24468146cc7991ce8fa77e110d197a03582501bc /target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
parent32e7340bf26d1d59aefb14bf1af4c2e3cb9a9642 (diff)
downloadupstream-0ff83e90ba5f0ed1d900813b470f61527500fdd8.tar.gz
upstream-0ff83e90ba5f0ed1d900813b470f61527500fdd8.tar.bz2
upstream-0ff83e90ba5f0ed1d900813b470f61527500fdd8.zip
add OCF 20100325 support to brcm-2.4
SVN-Revision: 21357
Diffstat (limited to 'target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch')
-rw-r--r--target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch b/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
new file mode 100644
index 0000000000..e176bf5366
--- /dev/null
+++ b/target/linux/generic-2.4/patches/900-ocf-kconfig-integration.patch
@@ -0,0 +1,21 @@
+--- a/crypto/Config.in
++++ b/crypto/Config.in
+@@ -117,4 +117,6 @@ if [ "$CONFIG_CRYPTO" = "y" ]; then
+ tristate ' Testing module' CONFIG_CRYPTO_TEST
+ fi
+
++source crypto/ocf/Config.in
++
+ endmenu
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -36,4 +36,9 @@ obj-$(CONFIG_CRYPTO_MICHAEL_MIC) += mich
+
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
++mod-subdirs += ocf
++subdir-$(CONFIG_OCF_OCF) += ocf
++ocf-$(CONFIG_OCF_OCF) = ocf/ocfdrv.o
++obj-$(CONFIG_OCF_OCF) += $(ocf-y)
++
+ include $(TOPDIR)/Rules.make