aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm63xx/image/Makefile')
-rw-r--r--target/linux/bcm63xx/image/Makefile25
1 files changed, 0 insertions, 25 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index eb4b78b06a..d7e2432bdb 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -96,31 +96,6 @@ define Image/FileSystemStrip
$(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
endef
-define Build/ad1018-jffs2-cferam
- mv $@ $@.kernel
-
- rm -rf $@-cferam
- mkdir -p $@-cferam
-
- # CFE RAM JFFS2 partition
- cp $(KDIR)/bcm63xx-cfe/$(CFE_RAM_FILE) $@-cferam/$(CFE_RAM_JFFS2_NAME)
- $(call Build/cfe-jffs2,$@-cferam)
- mv $@ $@.cferam
-
- # First block of CFE RAM 1 will be destroyed by MMAP
- dd if=$@.cferam bs=$(BLOCKSIZE) count=1 > $@
- dd if=$@.cferam >> $@
- $(call Build/pad-to,896k)
-
- # CFE RAM 2
- dd if=$@.cferam >> $@
-
- # Append kernel @ 4M
- $(call Build/pad-to,4096k)
- dd if=$@.kernel >> $@
- rm -f $@.kernel
-endef
-
define Build/cfe-bin
$(STAGING_DIR_HOST)/bin/imagetag -i $(IMAGE_KERNEL) -f $(IMAGE_ROOTFS) \
--output $@ --boardid $(CFE_BOARD_ID) --chipid $(CHIP_ID) \