aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/image/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-03 11:20:58 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2020-06-03 11:34:28 +0200
commit231f728f69e0451c44998187cc36ebb0ab9e9ea7 (patch)
tree6a2a7bdecbebedd9f4d8cdac4da1cc2d08947857 /target/linux/bcm63xx/image/Makefile
parent39f44be1dc85b0cf16ede5ae037cb0487fad0a9b (diff)
downloadupstream-231f728f69e0451c44998187cc36ebb0ab9e9ea7.tar.gz
upstream-231f728f69e0451c44998187cc36ebb0ab9e9ea7.tar.bz2
upstream-231f728f69e0451c44998187cc36ebb0ab9e9ea7.zip
bcm63xx: ad1018: remove cfe.bin image support
Apparently, Sercomm allows loading a BCM WFI image via CFE, but this image destroys "serial" and "protect" nand partitions, which is wrong. It will also set both bootflags to the same value, which causes booting issues with cferam (cferom will alternatively boot from cferam1 or cferam2 each time the device is rebooted). Now that OEM Sercomm images are supported it's time to remove this hacky cfe.bin image support. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx/image/Makefile')
-rw-r--r--target/linux/bcm63xx/image/Makefile25
1 files changed, 0 insertions, 25 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index eb4b78b06a..d7e2432bdb 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -96,31 +96,6 @@ define Image/FileSystemStrip
$(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
endef
-define Build/ad1018-jffs2-cferam
- mv $@ $@.kernel
-
- rm -rf $@-cferam
- mkdir -p $@-cferam
-
- # CFE RAM JFFS2 partition
- cp $(KDIR)/bcm63xx-cfe/$(CFE_RAM_FILE) $@-cferam/$(CFE_RAM_JFFS2_NAME)
- $(call Build/cfe-jffs2,$@-cferam)
- mv $@ $@.cferam
-
- # First block of CFE RAM 1 will be destroyed by MMAP
- dd if=$@.cferam bs=$(BLOCKSIZE) count=1 > $@
- dd if=$@.cferam >> $@
- $(call Build/pad-to,896k)
-
- # CFE RAM 2
- dd if=$@.cferam >> $@
-
- # Append kernel @ 4M
- $(call Build/pad-to,4096k)
- dd if=$@.kernel >> $@
- rm -f $@.kernel
-endef
-
define Build/cfe-bin
$(STAGING_DIR_HOST)/bin/imagetag -i $(IMAGE_KERNEL) -f $(IMAGE_ROOTFS) \
--output $@ --boardid $(CFE_BOARD_ID) --chipid $(CHIP_ID) \