aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile6
-rw-r--r--target/linux/at91/image/legacy.mk15
2 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index db480ac754..fedefe4287 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -51,6 +51,12 @@ define Device/evaluation-dtb
IMAGE/dtb := install-dtb
endef
+define Device/evaluation-fit
+ $(Device/evaluation)
+ KERNEL_SUFFIX := -fit-uImage.itb
+ KERNEL := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+endef
+
define Device/production
UBINIZE_OPTS := -E 5
IMAGES := factory.bin
diff --git a/target/linux/at91/image/legacy.mk b/target/linux/at91/image/legacy.mk
index be8c2db21c..c6d9ed8108 100644
--- a/target/linux/at91/image/legacy.mk
+++ b/target/linux/at91/image/legacy.mk
@@ -116,3 +116,18 @@ define Device/at91-q5xr5
KERNEL_SIZE := 2048k
endef
TARGET_DEVICES += at91-q5xr5
+
+define Device/wb45n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB45N
+ DEVICE_PACKAGES := \
+ kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+ kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+ kmod-leds-gpio
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+endef
+TARGET_DEVICES += wb45n
+