aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@gmail.com>2016-06-10 20:07:32 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:21 +0200
commit86d037e4a27fcf8f465fb1e79db727995ad5c684 (patch)
tree281bf815693ce01a1b75ed576146db18d6b51ce0 /target/linux/at91/image
parent618ed77a17422a9e167aed1eeec23a70235d0048 (diff)
downloadupstream-86d037e4a27fcf8f465fb1e79db727995ad5c684.tar.gz
upstream-86d037e4a27fcf8f465fb1e79db727995ad5c684.tar.bz2
upstream-86d037e4a27fcf8f465fb1e79db727995ad5c684.zip
at91: add support for the WB45N module from Laird
This module from Laird includes the following: - CPU Atmel SoC ARM926EJS - Wifi AR6003 - Bluetooth CSR8510 - RAM 64MB LPDDR - FLASH 128MB The flash is a dual image layout, kernel a/b, rootfs a/b, and a user partition. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile6
-rw-r--r--target/linux/at91/image/legacy.mk15
2 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index db480ac754..fedefe4287 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -51,6 +51,12 @@ define Device/evaluation-dtb
IMAGE/dtb := install-dtb
endef
+define Device/evaluation-fit
+ $(Device/evaluation)
+ KERNEL_SUFFIX := -fit-uImage.itb
+ KERNEL := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+endef
+
define Device/production
UBINIZE_OPTS := -E 5
IMAGES := factory.bin
diff --git a/target/linux/at91/image/legacy.mk b/target/linux/at91/image/legacy.mk
index be8c2db21c..c6d9ed8108 100644
--- a/target/linux/at91/image/legacy.mk
+++ b/target/linux/at91/image/legacy.mk
@@ -116,3 +116,18 @@ define Device/at91-q5xr5
KERNEL_SIZE := 2048k
endef
TARGET_DEVICES += at91-q5xr5
+
+define Device/wb45n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB45N
+ DEVICE_PACKAGES := \
+ kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+ kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+ kmod-leds-gpio
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+endef
+TARGET_DEVICES += wb45n
+