aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/feeds
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/feeds')
-rwxr-xr-xscripts/feeds6
1 files changed, 5 insertions, 1 deletions
diff --git a/scripts/feeds b/scripts/feeds
index 4ac6685b4d..4595c824a4 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -373,10 +373,14 @@ sub list {
return 0;
}
+# TODO: do_install_package etc. should deal with source packages rather
+# than binary packages
sub do_install_package($$) {
my $feed = shift;
my $pkg = shift;
- my $path = $pkg->{makefile};
+
+ my $path;
+ $pkg->{src} and $path = $pkg->{src}{makefile};
if($path) {
$path =~ s/\/Makefile$//;