aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/feeds
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-06 19:44:52 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-13 19:54:44 +0100
commit423ec18116f333bd51ff5264b0b5c9edc02945c6 (patch)
tree5774002c53a3263e4ea90db2bfec0ecb4aeb9507 /scripts/feeds
parentf0c702f124090470ec2b1140c576033e4e50fa1b (diff)
downloadupstream-423ec18116f333bd51ff5264b0b5c9edc02945c6.tar.gz
upstream-423ec18116f333bd51ff5264b0b5c9edc02945c6.tar.bz2
upstream-423ec18116f333bd51ff5264b0b5c9edc02945c6.zip
metadata: remove redundant fields from package hash
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'scripts/feeds')
-rwxr-xr-xscripts/feeds6
1 files changed, 5 insertions, 1 deletions
diff --git a/scripts/feeds b/scripts/feeds
index 4ac6685b4d..4595c824a4 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -373,10 +373,14 @@ sub list {
return 0;
}
+# TODO: do_install_package etc. should deal with source packages rather
+# than binary packages
sub do_install_package($$) {
my $feed = shift;
my $pkg = shift;
- my $path = $pkg->{makefile};
+
+ my $path;
+ $pkg->{src} and $path = $pkg->{src}{makefile};
if($path) {
$path =~ s/\/Makefile$//;