aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libunwind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libunwind/Makefile')
-rw-r--r--package/libs/libunwind/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
index c36cb5c290..994ee97a17 100644
--- a/package/libs/libunwind/Makefile
+++ b/package/libs/libunwind/Makefile
@@ -1,6 +1,6 @@
#
# Copyright (C) 2008-2013 OpenWrt.org
-# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
+# Copyright (C) 2017-2019 Yousong Zhou <yszhou4tech@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libunwind
-PKG_VERSION:=1.2.1
-PKG_RELEASE:=3
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=3f3ecb90e28cbe53fba7a4a27ccce7aad188d3210bb1964a923a731a27a75acb
+PKG_HASH:=43997a3939b6ccdf2f669b50fdb8a4d3205374728c2923ddc2354c65260214f8
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -32,7 +32,7 @@ define Package/libunwind
CATEGORY:=Libraries
TITLE:=The libunwind project
URL:=http://www.nongnu.org/libunwind/
- DEPENDS:=@((mips||mipsel||i386||x86_64||arm||aarch64)||(USE_GLIBC&&powerpc))
+ DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386)))
ABI_VERSION:=8
endef
@@ -42,6 +42,7 @@ endef
CONFIGURE_ARGS += \
--disable-documentation \
+ --disable-tests \
--enable-minidebuginfo=no \