aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libunwind/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-06-04 06:33:52 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-06-05 01:13:07 +0000
commitef7aa03bdb5e38b11a4430d1505e9398d587b467 (patch)
treea74bed51da50ee4978cf18ec32d6fee310b8a487 /package/libs/libunwind/Makefile
parent3209f5ae3d54e6f028e2e54314180a1be5b4896e (diff)
downloadupstream-ef7aa03bdb5e38b11a4430d1505e9398d587b467.tar.gz
upstream-ef7aa03bdb5e38b11a4430d1505e9398d587b467.tar.bz2
upstream-ef7aa03bdb5e38b11a4430d1505e9398d587b467.zip
libunwind: bump to version 1.3.1
Libunwind provides a sigreturn stub for x86 in version 1.2 [1]. However the arch still depends on setcontext() which is unavailable in musl-libc and which is supposed to be "deprecated everywhere" [2] [1] x86 sigreturn unimplemented for some libcs, https://github.com/libunwind/libunwind/issues/13 [2] setcontext deprecated on x86, https://github.com/libunwind/libunwind/issues/69 Refs: https://github.com/openwrt/packages/issues/8548#issuecomment-497791552 Reported-by: Rosen Penev <rosenp@gmail.com> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/libs/libunwind/Makefile')
-rw-r--r--package/libs/libunwind/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
index c36cb5c290..994ee97a17 100644
--- a/package/libs/libunwind/Makefile
+++ b/package/libs/libunwind/Makefile
@@ -1,6 +1,6 @@
#
# Copyright (C) 2008-2013 OpenWrt.org
-# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
+# Copyright (C) 2017-2019 Yousong Zhou <yszhou4tech@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libunwind
-PKG_VERSION:=1.2.1
-PKG_RELEASE:=3
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=3f3ecb90e28cbe53fba7a4a27ccce7aad188d3210bb1964a923a731a27a75acb
+PKG_HASH:=43997a3939b6ccdf2f669b50fdb8a4d3205374728c2923ddc2354c65260214f8
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -32,7 +32,7 @@ define Package/libunwind
CATEGORY:=Libraries
TITLE:=The libunwind project
URL:=http://www.nongnu.org/libunwind/
- DEPENDS:=@((mips||mipsel||i386||x86_64||arm||aarch64)||(USE_GLIBC&&powerpc))
+ DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386)))
ABI_VERSION:=8
endef
@@ -42,6 +42,7 @@ endef
CONFIGURE_ARGS += \
--disable-documentation \
+ --disable-tests \
--enable-minidebuginfo=no \