aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index e4b2064dc4..1909888e63 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -114,6 +114,27 @@ endef
$(eval $(call KernelPackage,bluetooth_6lowpan))
+define KernelPackage/btmrvl
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell Bluetooth Kernel Module support
+ DEPENDS:=+kmod-bluetooth +mwifiex-sdio-firmware
+ KCONFIG:= \
+ CONFIG_BT_MRVL \
+ CONFIG_BT_MRVL_SDIO
+ $(call AddDepends/bluetooth)
+ FILES:= \
+ $(LINUX_DIR)/drivers/bluetooth/btmrvl.ko \
+ $(LINUX_DIR)/drivers/bluetooth/btmrvl_sdio.ko
+ AUTOLOAD:=$(call AutoProbe,btmrvl btmrvl_sdio)
+endef
+
+define KernelPackage/btmrvl/description
+ Kernel support for Marvell SDIO Bluetooth Module
+endef
+
+$(eval $(call KernelPackage,btmrvl))
+
+
define KernelPackage/dma-buf
SUBMENU:=$(OTHER_MENU)
TITLE:=DMA shared buffer support