aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-07-07 09:43:10 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-17 00:59:55 +0200
commita5922f6c46dac91631714f3df491966bfe245b55 (patch)
tree2b779411d90c60de115a6dfd9e15db60f3961f8a /package/kernel/linux
parent8637110189769e9a6b733b3e1c38b4dce79cb4f5 (diff)
downloadupstream-a5922f6c46dac91631714f3df491966bfe245b55.tar.gz
upstream-a5922f6c46dac91631714f3df491966bfe245b55.tar.bz2
upstream-a5922f6c46dac91631714f3df491966bfe245b55.zip
kernel: bluetooth: add marvell sdio bluetooth module
This commit add support for Marvell bluetooth with SDIO interface. Signed-off-by: Henryk Heisig <hyniu@o2.pl> [Fix KCONFIG and FILES option] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index e4b2064dc4..1909888e63 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -114,6 +114,27 @@ endef
$(eval $(call KernelPackage,bluetooth_6lowpan))
+define KernelPackage/btmrvl
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell Bluetooth Kernel Module support
+ DEPENDS:=+kmod-bluetooth +mwifiex-sdio-firmware
+ KCONFIG:= \
+ CONFIG_BT_MRVL \
+ CONFIG_BT_MRVL_SDIO
+ $(call AddDepends/bluetooth)
+ FILES:= \
+ $(LINUX_DIR)/drivers/bluetooth/btmrvl.ko \
+ $(LINUX_DIR)/drivers/bluetooth/btmrvl_sdio.ko
+ AUTOLOAD:=$(call AutoProbe,btmrvl btmrvl_sdio)
+endef
+
+define KernelPackage/btmrvl/description
+ Kernel support for Marvell SDIO Bluetooth Module
+endef
+
+$(eval $(call KernelPackage,btmrvl))
+
+
define KernelPackage/dma-buf
SUBMENU:=$(OTHER_MENU)
TITLE:=DMA shared buffer support