aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index faee1f3674..177140e0fc 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -135,6 +135,22 @@ endef
$(eval $(call KernelPackage,sound-seq))
+define KernelPackage/sound-ens1371
+ TITLE:=(Creative) Ensoniq AudioPCI 1371
+ KCONFIG:=CONFIG_SND_ENS1371
+ DEPENDS:=@PCI_SUPPORT +kmod-ac97
+ FILES:=$(LINUX_DIR)/sound/pci/snd-ens1371.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-ens1371)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-ens1371/description
+ support for (Creative) Ensoniq AudioPCI 1371 chips
+endef
+
+$(eval $(call KernelPackage,sound-ens1371))
+
+
define KernelPackage/sound-i8x0
TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
DEPENDS:=+kmod-ac97