aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-03-21 18:49:29 +0100
committerFelix Fietkau <nbd@nbd.name>2018-03-25 21:18:35 +0200
commit83e1fce17abb51139e533cd0891e087ff4bbac64 (patch)
tree82e902a57136aaf4ccf7aa8f59b5cdb4b0988750 /package/kernel/linux/modules/sound.mk
parent287f5ebd2fe4fac6632819a1b539f119551407e8 (diff)
downloadupstream-83e1fce17abb51139e533cd0891e087ff4bbac64.tar.gz
upstream-83e1fce17abb51139e533cd0891e087ff4bbac64.tar.bz2
upstream-83e1fce17abb51139e533cd0891e087ff4bbac64.zip
kernel: add kmod-sound-ens1371
This audio chip is provided as a virtual audio device by VMware Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index faee1f3674..177140e0fc 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -135,6 +135,22 @@ endef
$(eval $(call KernelPackage,sound-seq))
+define KernelPackage/sound-ens1371
+ TITLE:=(Creative) Ensoniq AudioPCI 1371
+ KCONFIG:=CONFIG_SND_ENS1371
+ DEPENDS:=@PCI_SUPPORT +kmod-ac97
+ FILES:=$(LINUX_DIR)/sound/pci/snd-ens1371.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-ens1371)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-ens1371/description
+ support for (Creative) Ensoniq AudioPCI 1371 chips
+endef
+
+$(eval $(call KernelPackage,sound-ens1371))
+
+
define KernelPackage/sound-i8x0
TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
DEPENDS:=+kmod-ac97