aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 0a8115c28b..56cd0ec995 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -298,6 +298,21 @@ endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+define KernelPackage/hwmon-w83793
+ TITLE:=Winbond W83793G/R monitoring support
+ KCONFIG:=CONFIG_SENSORS_W83793
+ FILES:=$(LINUX_DIR)/drivers/hwmon/w83793.ko
+ AUTOLOAD:=$(call AutoProbe,w83793)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-w83793/description
+ Kernel module for the Winbond W83793G and W83793R chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-w83793))
+
+
define KernelPackage/hwmon-gsc
TITLE:=Gateworks GSC monitoring support
KCONFIG:=CONFIG_SENSORS_GSC