aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorFlorian Larysch <fl@n621.de>2016-08-04 14:04:26 +0200
committerFelix Fietkau <nbd@nbd.name>2016-11-08 05:49:58 +0100
commit51b1d76f16c2a18b791d95bec556d07b1b6c8a3d (patch)
treed4e0d198b43b8fb25164a8675fe76408c52da334 /package/kernel/linux/modules/hwmon.mk
parent519a199cbcc0930e229ddd7087309326a846bdce (diff)
downloadupstream-51b1d76f16c2a18b791d95bec556d07b1b6c8a3d.tar.gz
upstream-51b1d76f16c2a18b791d95bec556d07b1b6c8a3d.tar.bz2
upstream-51b1d76f16c2a18b791d95bec556d07b1b6c8a3d.zip
kernel: package module for the W83793 hwmon chips
Package the driver for the W83793 hwmon chip present on the T4240RDB. Signed-off-by: Florian Larysch <fl@n621.de>
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 0a8115c28b..56cd0ec995 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -298,6 +298,21 @@ endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+define KernelPackage/hwmon-w83793
+ TITLE:=Winbond W83793G/R monitoring support
+ KCONFIG:=CONFIG_SENSORS_W83793
+ FILES:=$(LINUX_DIR)/drivers/hwmon/w83793.ko
+ AUTOLOAD:=$(call AutoProbe,w83793)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-w83793/description
+ Kernel module for the Winbond W83793G and W83793R chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-w83793))
+
+
define KernelPackage/hwmon-gsc
TITLE:=Gateworks GSC monitoring support
KCONFIG:=CONFIG_SENSORS_GSC