aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index ded6d3bb84..b1e27f22c3 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -54,12 +54,18 @@ system calls a program makes while it is running.
endef
define Package/strace/config
+config PACKAGE_strace_libdw
+ bool "Enable stack tracing support using libdw"
+ default n
config PACKAGE_strace_libunwind
bool "Enable stack tracing support using libunwind (experimental)"
default n
endef
-CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+CONFIGURE_ARGS += \
+ --with-libdw=$(if $(CONFIG_PACKAGE_strace_libdw),yes,no) \
+ --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"