aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-10-02 19:55:11 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2018-10-02 19:57:33 +0300
commit7378ca79b9ecc30ddfbe6d965707f1e4f5ebf792 (patch)
tree20598549d0056a062dd1035bcb065c9bc9311222 /package/devel
parent7bfe757bc46bc43612890a006fe8a843202ebbb5 (diff)
downloadupstream-7378ca79b9ecc30ddfbe6d965707f1e4f5ebf792.tar.gz
upstream-7378ca79b9ecc30ddfbe6d965707f1e4f5ebf792.tar.bz2
upstream-7378ca79b9ecc30ddfbe6d965707f1e4f5ebf792.zip
strace: add option to enable libdw stack tracing
Fixes build with CONFIG_libdw=y. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index ded6d3bb84..b1e27f22c3 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -54,12 +54,18 @@ system calls a program makes while it is running.
endef
define Package/strace/config
+config PACKAGE_strace_libdw
+ bool "Enable stack tracing support using libdw"
+ default n
config PACKAGE_strace_libunwind
bool "Enable stack tracing support using libunwind (experimental)"
default n
endef
-CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+CONFIGURE_ARGS += \
+ --with-libdw=$(if $(CONFIG_PACKAGE_strace_libdw),yes,no) \
+ --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"