aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/arm-trusted-firmware-sunxi/Makefile6
-rw-r--r--package/boot/uboot-sunxi/Makefile10
-rw-r--r--package/boot/uboot-sunxi/uEnv-h6.txt7
3 files changed, 23 insertions, 0 deletions
diff --git a/package/boot/arm-trusted-firmware-sunxi/Makefile b/package/boot/arm-trusted-firmware-sunxi/Makefile
index e2a11c8bd7..0abfbae750 100644
--- a/package/boot/arm-trusted-firmware-sunxi/Makefile
+++ b/package/boot/arm-trusted-firmware-sunxi/Makefile
@@ -37,6 +37,11 @@ define Package/arm-trusted-firmware-sunxi-a64
VARIANT:=sun50i_a64
endef
+define Package/arm-trusted-firmware-sunxi-h6
+ $(call Package/arm-trusted-firmware-sunxi/Default)
+ VARIANT:=sun50i_h6
+endef
+
export GCC_HONOUR_COPTS=s
MAKE_VARS = \
@@ -55,3 +60,4 @@ define Package/arm-trusted-firmware-sunxi/install
endef
$(eval $(call BuildPackage,arm-trusted-firmware-sunxi-a64))
+$(eval $(call BuildPackage,arm-trusted-firmware-sunxi-h6))
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 18288cdd3a..17f1c0d158 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -204,6 +204,15 @@ define U-Boot/orangepi_one
BUILD_DEVICES:=xunlong_orangepi-one
endef
+define U-Boot/orangepi_one_plus
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=Orange Pi One Plus (H6)
+ DEPENDS:=+PACKAGE_u-boot-orangepi_one_plus:arm-trusted-firmware-sunxi-h6
+ BUILD_DEVICES:=xunlong_orangepi-one-plus
+ UENV:=h6
+ ATF:=h6
+endef
+
define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
@@ -344,6 +353,7 @@ UBOOT_TARGETS := \
orangepi_zero \
orangepi_r1 \
orangepi_one \
+ orangepi_one_plus \
orangepi_pc \
orangepi_pc_plus \
orangepi_plus \
diff --git a/package/boot/uboot-sunxi/uEnv-h6.txt b/package/boot/uboot-sunxi/uEnv-h6.txt
new file mode 100644
index 0000000000..78810ff223
--- /dev/null
+++ b/package/boot/uboot-sunxi/uEnv-h6.txt
@@ -0,0 +1,7 @@
+setenv mmc_rootpart 2
+part uuid mmc ${mmc_bootdev}:${mmc_rootpart} uuid
+setenv loadkernel fatload mmc \$mmc_bootdev \$kernel_addr_r uImage
+setenv loaddtb fatload mmc \$mmc_bootdev \$fdt_addr_r dtb
+setenv bootargs console=ttyS0,115200 earlyprintk root=PARTUUID=${uuid} rootwait
+setenv uenvcmd run loadkernel \&\& run loaddtb \&\& booti \$kernel_addr_r - \$fdt_addr_r
+run uenvcmd