aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2020-04-24 09:58:53 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2021-04-11 23:14:55 +0200
commit3225241c2bc61e907ea2980cd2f14ea6589cdf2d (patch)
treeba2c6a1e637ac8a24c3f03449157b314a290c342 /package/boot
parentc2163530db3c95745c822e4a573a220ba9f98ca7 (diff)
downloadupstream-3225241c2bc61e907ea2980cd2f14ea6589cdf2d.tar.gz
upstream-3225241c2bc61e907ea2980cd2f14ea6589cdf2d.tar.bz2
upstream-3225241c2bc61e907ea2980cd2f14ea6589cdf2d.zip
sunxi: add support for H6 boards and OrangePiOnePlus
Specifications: SoC Allwinner H6 @ 1.8 Ghz DRAM 1Gb LPDDR3 Power DC 5V @ 3A Video HDMI (Type 2.0A - full) Audio HDMI, on-board microphone Network 10/100/1000Mbps Ethernet (Realtek RTL8211) Storage microSD USB 1 USB2.0 Host, 1 USB2.0 OTG Debug Serial UART Flashing instructions: Standard sunxi SD card installation procedure - copy image to SD card, insert into SD card slot on the device and boot. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/arm-trusted-firmware-sunxi/Makefile6
-rw-r--r--package/boot/uboot-sunxi/Makefile10
-rw-r--r--package/boot/uboot-sunxi/uEnv-h6.txt7
3 files changed, 23 insertions, 0 deletions
diff --git a/package/boot/arm-trusted-firmware-sunxi/Makefile b/package/boot/arm-trusted-firmware-sunxi/Makefile
index e2a11c8bd7..0abfbae750 100644
--- a/package/boot/arm-trusted-firmware-sunxi/Makefile
+++ b/package/boot/arm-trusted-firmware-sunxi/Makefile
@@ -37,6 +37,11 @@ define Package/arm-trusted-firmware-sunxi-a64
VARIANT:=sun50i_a64
endef
+define Package/arm-trusted-firmware-sunxi-h6
+ $(call Package/arm-trusted-firmware-sunxi/Default)
+ VARIANT:=sun50i_h6
+endef
+
export GCC_HONOUR_COPTS=s
MAKE_VARS = \
@@ -55,3 +60,4 @@ define Package/arm-trusted-firmware-sunxi/install
endef
$(eval $(call BuildPackage,arm-trusted-firmware-sunxi-a64))
+$(eval $(call BuildPackage,arm-trusted-firmware-sunxi-h6))
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 18288cdd3a..17f1c0d158 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -204,6 +204,15 @@ define U-Boot/orangepi_one
BUILD_DEVICES:=xunlong_orangepi-one
endef
+define U-Boot/orangepi_one_plus
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=Orange Pi One Plus (H6)
+ DEPENDS:=+PACKAGE_u-boot-orangepi_one_plus:arm-trusted-firmware-sunxi-h6
+ BUILD_DEVICES:=xunlong_orangepi-one-plus
+ UENV:=h6
+ ATF:=h6
+endef
+
define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
@@ -344,6 +353,7 @@ UBOOT_TARGETS := \
orangepi_zero \
orangepi_r1 \
orangepi_one \
+ orangepi_one_plus \
orangepi_pc \
orangepi_pc_plus \
orangepi_plus \
diff --git a/package/boot/uboot-sunxi/uEnv-h6.txt b/package/boot/uboot-sunxi/uEnv-h6.txt
new file mode 100644
index 0000000000..78810ff223
--- /dev/null
+++ b/package/boot/uboot-sunxi/uEnv-h6.txt
@@ -0,0 +1,7 @@
+setenv mmc_rootpart 2
+part uuid mmc ${mmc_bootdev}:${mmc_rootpart} uuid
+setenv loadkernel fatload mmc \$mmc_bootdev \$kernel_addr_r uImage
+setenv loaddtb fatload mmc \$mmc_bootdev \$fdt_addr_r dtb
+setenv bootargs console=ttyS0,115200 earlyprintk root=PARTUUID=${uuid} rootwait
+setenv uenvcmd run loadkernel \&\& run loaddtb \&\& booti \$kernel_addr_r - \$fdt_addr_r
+run uenvcmd