aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-rockchip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-rockchip/Makefile')
-rw-r--r--package/boot/uboot-rockchip/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index 645422aca4..75825ce690 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -38,6 +38,16 @@ endef
# RK3399 boards
+define U-Boot/nanopi-r4s-rk3399
+ BUILD_SUBTARGET:=armv8
+ NAME:=NanoPi R4S
+ BUILD_DEVICES:= \
+ friendlyarm_nanopi-r4s
+ DEPENDS:=+PACKAGE_u-boot-nanopi-r4s-rk3399:arm-trusted-firmware-rockchip
+ PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip
+ ATF:=rk3399_bl31.elf
+endef
+
define U-Boot/rock-pi-4-rk3399
BUILD_SUBTARGET:=armv8
NAME:=Rock Pi 4
@@ -59,6 +69,7 @@ define U-Boot/rockpro64-rk3399
endef
UBOOT_TARGETS := \
+ nanopi-r4s-rk3399 \
rock-pi-4-rk3399 \
rockpro64-rk3399 \
nanopi-r2s-rk3328