aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-rockchip/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2021-05-13 21:49:59 +0800
committerDavid Bauer <mail@david-bauer.net>2021-06-10 10:34:44 +0200
commit52dc7995f73c80598ef37c2f9ccf6016163f9b4b (patch)
treee8504495dad3fdaa1073740ddc6d1e4dbd2cef9a /package/boot/uboot-rockchip/Makefile
parent82bec3364de557eb21ef85e1993468ba535e540b (diff)
downloadupstream-52dc7995f73c80598ef37c2f9ccf6016163f9b4b.tar.gz
upstream-52dc7995f73c80598ef37c2f9ccf6016163f9b4b.tar.bz2
upstream-52dc7995f73c80598ef37c2f9ccf6016163f9b4b.zip
uboot-rockchip: add NanoPi R4S support
Add support for the FriendlyARM NanoPi R4S. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'package/boot/uboot-rockchip/Makefile')
-rw-r--r--package/boot/uboot-rockchip/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index 645422aca4..75825ce690 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -38,6 +38,16 @@ endef
# RK3399 boards
+define U-Boot/nanopi-r4s-rk3399
+ BUILD_SUBTARGET:=armv8
+ NAME:=NanoPi R4S
+ BUILD_DEVICES:= \
+ friendlyarm_nanopi-r4s
+ DEPENDS:=+PACKAGE_u-boot-nanopi-r4s-rk3399:arm-trusted-firmware-rockchip
+ PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip
+ ATF:=rk3399_bl31.elf
+endef
+
define U-Boot/rock-pi-4-rk3399
BUILD_SUBTARGET:=armv8
NAME:=Rock Pi 4
@@ -59,6 +69,7 @@ define U-Boot/rockpro64-rk3399
endef
UBOOT_TARGETS := \
+ nanopi-r4s-rk3399 \
rock-pi-4-rk3399 \
rockpro64-rk3399 \
nanopi-r2s-rk3328