aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/alsa
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/target/linux/package/alsa')
-rw-r--r--openwrt/target/linux/package/alsa/Config.in9
-rw-r--r--openwrt/target/linux/package/alsa/Makefile60
-rw-r--r--openwrt/target/linux/package/alsa/files/alsa.modules10
-rw-r--r--openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control5
-rw-r--r--openwrt/target/linux/package/alsa/patches/100-compile_fix.patch18
5 files changed, 0 insertions, 102 deletions
diff --git a/openwrt/target/linux/package/alsa/Config.in b/openwrt/target/linux/package/alsa/Config.in
deleted file mode 100644
index df4da0b7d1..0000000000
--- a/openwrt/target/linux/package/alsa/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_KMOD_ALSA
- prompt "kmod-alsa......................... Alsa Sound Drivers"
- tristate
- depends BR2_LINUX_2_4_X86 || BR2_LINUX_2_4_BRCM || BR2_LINUX_2_6_X86 || BR2_LINUX_2_6_BRCM
- depends BR2_PACKAGE_KMOD_USB_CONTROLLER
- select BR2_PACKAGE_KMOD_SOUNDCORE
- default m if CONFIG_DEVEL
- help
- Alsa Drivers for USB Soundcards
diff --git a/openwrt/target/linux/package/alsa/Makefile b/openwrt/target/linux/package/alsa/Makefile
deleted file mode 100644
index 665fc00451..0000000000
--- a/openwrt/target/linux/package/alsa/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include ../../rules.mk
-
-PKG_NAME:=alsa-driver
-PKG_VERSION:=1.0.11rc4
-PKG_RELEASE:=1
-PKG_MD5SUM:=8e5794026082a964b09b46f9d881e6ec
-
-PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
-KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
-endif
-ifeq ($(LINUX_KARCH),mips)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
-KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
-endif
-
-$(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); \
- CFLAGS="$(KERNEL_C_INCS)" \
- ./configure \
- --with-build=$(LINUX_DIR) \
- --with-kernel=$(LINUX_DIR) \
- --with-cross=$(KERNEL_CROSS) \
- --with-redhat=no \
- --with-suse=no \
- --with-oss=yes \
- --with-isapnp=no \
- --with-sequencer=no \
- --with-cards=usb-audio \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- c_opts="$(KERNEL_C_OPTS)" \
- all
- touch $@
-
-$(IPKG_KMOD_ALSA):
- install -d -m0755 $(IDIR_KMOD_ALSA)/etc/modules.d
- install -m0644 ./files/alsa.modules $(IDIR_KMOD_ALSA)/etc/modules.d/70-alsa
- install -d -m0755 $(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)
- install -m0644 $(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX) \
- $(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)/
- $(IPKG_BUILD) $(IDIR_KMOD_ALSA) $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/package/alsa/files/alsa.modules b/openwrt/target/linux/package/alsa/files/alsa.modules
deleted file mode 100644
index 6b16c8c586..0000000000
--- a/openwrt/target/linux/package/alsa/files/alsa.modules
+++ /dev/null
@@ -1,10 +0,0 @@
-snd-page-alloc
-snd
-snd-timer
-snd-pcm
-snd-rawmidi
-snd-usb-lib
-snd-hwdep
-snd-usb-audio
-snd-mixer-oss
-snd-pcm-oss
diff --git a/openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control b/openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control
deleted file mode 100644
index 5641785d84..0000000000
--- a/openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: kmod-alsa
-Priority: optional
-Section: sys
-Depends: kmod-usb-audio
-Description: Alsa Drivers for USB Soundcards
diff --git a/openwrt/target/linux/package/alsa/patches/100-compile_fix.patch b/openwrt/target/linux/package/alsa/patches/100-compile_fix.patch
deleted file mode 100644
index 2e2a3df79a..0000000000
--- a/openwrt/target/linux/package/alsa/patches/100-compile_fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -urN alsa.old/include/adriver.h alsa.dev/include/adriver.h
---- alsa.old/include/adriver.h 2006-04-19 08:24:30.000000000 +0200
-+++ alsa.dev/include/adriver.h 2006-05-31 17:24:49.000000000 +0200
-@@ -451,7 +451,7 @@
- #endif /* < 2.6.0 */
-
- /* workarounds for USB API */
--#if defined(SND_NEED_USB_WRAPPER) && (defined(CONFIG_USB) || defined(CONFIG_USB_MODULE))
-+#if 1
-
- #include <linux/usb.h>
-
-@@ -1174,4 +1174,5 @@
- */
- #define OPL3_HW_OPL3_PC98 0x0305 /* PC9800 */
-
-+#undef info /* used in several structs */
- #endif /* __SOUND_LOCAL_DRIVER_H */