aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 29b6fbdaa6..496fc04f1b 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -156,6 +156,12 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
+$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
+ mkdir -p $(dir $@)
+ $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
+
+prereq: $(STAGING_DIR_HOST)/bin/mkhash
+
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
touch $(STAGING_DIR_HOST)/bin/ldconfig && \