aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-25 16:23:34 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:12 +0100
commitdad48c6438f0a4c42ad34842a88e82280d971d90 (patch)
tree3db2a4c5b4d2af5f927421f2ad03825c4375fda5 /include/prereq-build.mk
parenta0993dda5f4c7f69748d527e255522c0e5afeb81 (diff)
downloadupstream-dad48c6438f0a4c42ad34842a88e82280d971d90.tar.gz
upstream-dad48c6438f0a4c42ad34842a88e82280d971d90.tar.bz2
upstream-dad48c6438f0a4c42ad34842a88e82280d971d90.zip
build: add a small standalone utility for calculating md5/sha256 hash
This will be used to simplify the build system code for checking hashes. Instead of using various variants of md5sum / openssl, use one simple utility for all of them Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 29b6fbdaa6..496fc04f1b 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -156,6 +156,12 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
+$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
+ mkdir -p $(dir $@)
+ $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
+
+prereq: $(STAGING_DIR_HOST)/bin/mkhash
+
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
touch $(STAGING_DIR_HOST)/bin/ldconfig && \