aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 70c09ad90c..56bad539b3 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -274,6 +274,13 @@ define Build/combined-image
@mv $@.new $@
endef
+define Build/linksys-image
+ $(TOPDIR)/scripts/linksys-image.sh \
+ "$(call param_get_default,type,$(1),$(DEVICE_NAME))" \
+ $@ $@.new
+ mv $@.new $@
+endef
+
define Build/openmesh-image
$(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
"$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \