aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorOever González <notengobattery@gmail.com>2019-01-23 21:20:55 -0600
committerChristian Lamparter <chunkeey@gmail.com>2019-01-26 21:43:07 +0100
commit892d741259ae1f8c4b18ba8ae26c7f85f83f6340 (patch)
tree8c5f3493eeab98d186b433435892958f080cff1e /include/image-commands.mk
parentc43acdf34201c33a6139eca7d3e9e3913e841b59 (diff)
downloadupstream-892d741259ae1f8c4b18ba8ae26c7f85f83f6340.tar.gz
upstream-892d741259ae1f8c4b18ba8ae26c7f85f83f6340.tar.bz2
upstream-892d741259ae1f8c4b18ba8ae26c7f85f83f6340.zip
build: add a script for generating Linksys factory images
This commit adds the 'Build/linksys-image' rule and the 'linksys-image.sh' script to the build system. This change is needed for generating factory images for the Linksys EA6350v3 device. Without this patch, only valid sysupgrade images can be generated. With this patch, users can flash the device without the need of physical access or disassembly. Signed-off-by: Ryan Pannell <ryan@osukl.com> Signed-off-by: Oever González <notengobattery@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 70c09ad90c..56bad539b3 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -274,6 +274,13 @@ define Build/combined-image
@mv $@.new $@
endef
+define Build/linksys-image
+ $(TOPDIR)/scripts/linksys-image.sh \
+ "$(call param_get_default,type,$(1),$(DEVICE_NAME))" \
+ $@ $@.new
+ mv $@.new $@
+endef
+
define Build/openmesh-image
$(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
"$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \