aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 293409d8b7..c26c8e547e 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -20,6 +20,7 @@ define rdep
.SILENT: $(2)_check
$(2): $(2)_check
+ check-depends: $(2)_check
ifneq ($(wildcard $(2)),)
$(2)_check::
@@ -46,3 +47,8 @@ endif
endef
+ifeq ($(filter .%,$(MAKECMDGOALS)),$(if $(MAKECMDGOALS),$(MAKECMDGOALS),x))
+ define rdep
+ $(2): $(2)_check
+ endef
+endif