aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 14:27:04 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:08 +0100
commit9228d1c066cf3a2cd01288bed3646e53638705b6 (patch)
treee5e9af619fd75d10b58f4088191ca2adec64549c /include/depends.mk
parent6cf067d084cc551c721e98b6d6c6403a63e521d5 (diff)
downloadupstream-9228d1c066cf3a2cd01288bed3646e53638705b6.tar.gz
upstream-9228d1c066cf3a2cd01288bed3646e53638705b6.tar.bz2
upstream-9228d1c066cf3a2cd01288bed3646e53638705b6.zip
build: introduce extra targets that contain only proper dependencies
This can be used to check if targets like prepare or compile are up to date Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 293409d8b7..c26c8e547e 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -20,6 +20,7 @@ define rdep
.SILENT: $(2)_check
$(2): $(2)_check
+ check-depends: $(2)_check
ifneq ($(wildcard $(2)),)
$(2)_check::
@@ -46,3 +47,8 @@ endif
endef
+ifeq ($(filter .%,$(MAKECMDGOALS)),$(if $(MAKECMDGOALS),$(MAKECMDGOALS),x))
+ define rdep
+ $(2): $(2)_check
+ endef
+endif