aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 43ed005b8a..fffc3bf5da 100644
--- a/Makefile
+++ b/Makefile
@@ -90,8 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
$< -o Config.in
menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
- @[ -f .config ] || \
- [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config
+ @[ -f .config ] || { \
+ [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+ }
$< Config.in
kernel_menuconfig: .config FORCE