aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-07 10:31:46 +0000
committerMike Baker <mbm@openwrt.org>2007-04-07 10:31:46 +0000
commit5e42783559a06133e33601344a0222e49d58aee5 (patch)
treebf0c98fb1d2c434f82f87757cd0451f2a42b3f62 /Makefile
parent3c4dd6fb024967d1b3bb605ba2ef9c619c95daf4 (diff)
downloadupstream-5e42783559a06133e33601344a0222e49d58aee5.tar.gz
upstream-5e42783559a06133e33601344a0222e49d58aee5.tar.bz2
upstream-5e42783559a06133e33601344a0222e49d58aee5.zip
fix menuconfig checks
SVN-Revision: 6879
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 43ed005b8a..fffc3bf5da 100644
--- a/Makefile
+++ b/Makefile
@@ -90,8 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
$< -o Config.in
menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
- @[ -f .config ] || \
- [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config
+ @[ -f .config ] || { \
+ [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+ }
$< Config.in
kernel_menuconfig: .config FORCE