aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 348e645005..5257a990dc 100644
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,10 @@ LC_ALL:=C
LANG:=C
export TOPDIR LC_ALL LANG
+empty:=
+space:= $(empty) $(empty)
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+
world:
include $(TOPDIR)/include/host.mk