aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-21 02:00:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-21 02:00:11 +0000
commit43f34a93e6d61d206126b47c92d999b286f5a7c8 (patch)
tree0366cf1d155f0ca36d0fe26c5cede022653f549b /Makefile
parentf1f388d52707cb74a23f35ccf208fdf064712c11 (diff)
downloadupstream-43f34a93e6d61d206126b47c92d999b286f5a7c8.tar.gz
upstream-43f34a93e6d61d206126b47c92d999b286f5a7c8.tar.bz2
upstream-43f34a93e6d61d206126b47c92d999b286f5a7c8.zip
Makefile: add a check to bail out early when the path to the openwrt directory contains spaces (#12344)
SVN-Revision: 33884
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 348e645005..5257a990dc 100644
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,10 @@ LC_ALL:=C
LANG:=C
export TOPDIR LC_ALL LANG
+empty:=
+space:= $(empty) $(empty)
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+
world:
include $(TOPDIR)/include/host.mk