aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/utils/iptables/patches/600-shared-libext.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/network/utils/iptables/patches/600-shared-libext.patch b/package/network/utils/iptables/patches/600-shared-libext.patch
index 92f5485399..1b7982a056 100644
--- a/package/network/utils/iptables/patches/600-shared-libext.patch
+++ b/package/network/utils/iptables/patches/600-shared-libext.patch
@@ -76,3 +76,23 @@ Index: iptables-1.4.21/iptables/Makefile.am
endif
xtables_multi_SOURCES += xshared.c
xtables_multi_LDADD += ../libxtables/libxtables.la -lm
+@@ -32,7 +35,8 @@ if ENABLE_NFTABLES
+ BUILT_SOURCES += xtables-config-parser.h
+ xtables_compat_multi_SOURCES = xtables-compat-multi.c iptables-xml.c
+ xtables_compat_multi_CFLAGS = ${AM_CFLAGS}
+-xtables_compat_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
++xtables_compat_multi_LDADD =
++xtables_compat_multi_LDFLAGS = -L../extensions/ -liptext -liptext_ebt
+ if ENABLE_STATIC
+ xtables_compat_multi_CFLAGS += -DALL_INCLUSIVE
+ endif
+@@ -45,7 +49,8 @@ xtables_compat_multi_SOURCES += xtables-
+ getethertype.c nft-bridge.c \
+ xtables-eb-standalone.c xtables-eb.c \
+ xtables-translate.c
+-xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS} ../extensions/libext4.a ../extensions/libext6.a ../extensions/libext_ebt.a ../extensions/libext_arpt.a
++xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS}
++xtables_compat_multi_LDFLAGS += -liptext4 -liptext6 -liptext_arpt
+ # yacc and lex generate dirty code
+ xtables_compat_multi-xtables-config-parser.o xtables_compat_multi-xtables-config-syntax.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
+ xtables_compat_multi_SOURCES += xshared.c