aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrektide de la faye <rektide@voodoowarez.com>2017-12-14 01:29:11 -0500
committerHans Dedecker <dedeckeh@gmail.com>2018-01-02 08:00:37 +0100
commitda126d557c6d1cfe19d3f93481af6e00631d7931 (patch)
treeef3900c17fe977420a192b2292593f1e56c1ab3d
parent473e99457156209bf37ab15b4b7f3ed94b15dc0c (diff)
downloadupstream-da126d557c6d1cfe19d3f93481af6e00631d7931.tar.gz
upstream-da126d557c6d1cfe19d3f93481af6e00631d7931.tar.bz2
upstream-da126d557c6d1cfe19d3f93481af6e00631d7931.zip
iptables: fix nftables compile issue (FS#711)
Enabling IPTABLES_NFTABLES resulted in an error during build:# *** No rule to make target '../extensions/libext.a', needed by 'xtables-compat-multi'." Comments from Alexander Lochmann and Fedor Konstantinov in FS#711 provided fixes for this build error, allowing iptables to compile. https://bugs.lede-project.org/index.php?do=details&task_id=711. This commit updates the Makefile.am xtables_compat_multi_LDFLAGS and _LDADD, moving linking of extensions to LDFLAGS. Signed-off-by: rektide de la faye <rektide@voodoowarez.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
-rw-r--r--package/network/utils/iptables/patches/600-shared-libext.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/network/utils/iptables/patches/600-shared-libext.patch b/package/network/utils/iptables/patches/600-shared-libext.patch
index 92f5485399..1b7982a056 100644
--- a/package/network/utils/iptables/patches/600-shared-libext.patch
+++ b/package/network/utils/iptables/patches/600-shared-libext.patch
@@ -76,3 +76,23 @@ Index: iptables-1.4.21/iptables/Makefile.am
endif
xtables_multi_SOURCES += xshared.c
xtables_multi_LDADD += ../libxtables/libxtables.la -lm
+@@ -32,7 +35,8 @@ if ENABLE_NFTABLES
+ BUILT_SOURCES += xtables-config-parser.h
+ xtables_compat_multi_SOURCES = xtables-compat-multi.c iptables-xml.c
+ xtables_compat_multi_CFLAGS = ${AM_CFLAGS}
+-xtables_compat_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
++xtables_compat_multi_LDADD =
++xtables_compat_multi_LDFLAGS = -L../extensions/ -liptext -liptext_ebt
+ if ENABLE_STATIC
+ xtables_compat_multi_CFLAGS += -DALL_INCLUSIVE
+ endif
+@@ -45,7 +49,8 @@ xtables_compat_multi_SOURCES += xtables-
+ getethertype.c nft-bridge.c \
+ xtables-eb-standalone.c xtables-eb.c \
+ xtables-translate.c
+-xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS} ../extensions/libext4.a ../extensions/libext6.a ../extensions/libext_ebt.a ../extensions/libext_arpt.a
++xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS}
++xtables_compat_multi_LDFLAGS += -liptext4 -liptext6 -liptext_arpt
+ # yacc and lex generate dirty code
+ xtables_compat_multi-xtables-config-parser.o xtables_compat_multi-xtables-config-syntax.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
+ xtables_compat_multi_SOURCES += xshared.c