aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--include/toplevel.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index f1577ad4d1..0144b0c5ff 100644
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,7 @@ dirclean: clean
cacheclean:
ifneq ($(CONFIG_CCACHE),)
- rm -rf $(CCACHE_DIR)
+ $(STAGING_DIR_HOST)/bin/ccache -C
endif
ifndef DUMP_TARGET_DB
diff --git a/include/toplevel.mk b/include/toplevel.mk
index d3500ef58f..23bae149d4 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -261,8 +261,8 @@ package/symlinks-clean:
help:
cat README.md
-distclean: cacheclean
- rm -rf bin build_dir .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
+distclean:
+ rm -rf bin build_dir .ccache .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
@$(_SINGLE)$(SUBMAKE) -C scripts/config clean
ifeq ($(findstring v,$(DEBUG)),)