aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Wegener <sven.wegener@stealer.net>2021-01-01 11:46:04 +0100
committerPaul Spooren <mail@aparcar.org>2021-01-06 15:31:18 -1000
commitcd5f66652bd405872fc33ca6410dc8f9b51fee09 (patch)
tree72e357ada8cc62c69b25aab088bd6aee6e33b0df
parente02a41f67db52726d3c2c9e4e50e51a5510e0a27 (diff)
downloadupstream-cd5f66652bd405872fc33ca6410dc8f9b51fee09.tar.gz
upstream-cd5f66652bd405872fc33ca6410dc8f9b51fee09.tar.bz2
upstream-cd5f66652bd405872fc33ca6410dc8f9b51fee09.zip
build: use ccache -C for cleaning the cache
This keeps the configuration, like the size of the cache, and the statistics intact. Move the removal of the cache directory to the distclean target, but only delete the .ccache directory inside of our build tree, as we should not mess with a user-configured external ccache directory this destructively. Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
-rw-r--r--Makefile2
-rw-r--r--include/toplevel.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index f1577ad4d1..0144b0c5ff 100644
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,7 @@ dirclean: clean
cacheclean:
ifneq ($(CONFIG_CCACHE),)
- rm -rf $(CCACHE_DIR)
+ $(STAGING_DIR_HOST)/bin/ccache -C
endif
ifndef DUMP_TARGET_DB
diff --git a/include/toplevel.mk b/include/toplevel.mk
index d3500ef58f..23bae149d4 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -261,8 +261,8 @@ package/symlinks-clean:
help:
cat README.md
-distclean: cacheclean
- rm -rf bin build_dir .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
+distclean:
+ rm -rf bin build_dir .ccache .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
@$(_SINGLE)$(SUBMAKE) -C scripts/config clean
ifeq ($(findstring v,$(DEBUG)),)