aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/download.mk2
-rwxr-xr-xscripts/download.pl6
2 files changed, 7 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 8a1205df00..ca5eee4e02 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -13,7 +13,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
define dl_method
$(strip \
$(if $(2),$(2), \
- $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+ $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \
diff --git a/scripts/download.pl b/scripts/download.pl
index 9d1fe4755a..25c73fbeb5 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
@@ -176,6 +176,12 @@ foreach my $mirror (@ARGV) {
for (1 .. 5) {
push @mirrors, "http://downloads.sourceforge.net/$1";
}
+ } elsif ($mirror =~ /^\@APACHE\/(.+)$/) {
+ push @mirrors, "http://ftp.tudelft.nl/apache/$1";
+ push @mirrors, "http://apache.openmirror.de/$1";
+ push @mirrors, "http://mirrors.ocf.berkeley.edu/apache/$1";
+ push @mirrors, "http://mirror.cc.columbia.edu/pub/software/apache/$1";
+ push @mirrors, "http://ftp.jaist.ac.jp/pub/apache/$1";
} elsif ($mirror =~ /^\@GNU\/(.+)$/) {
push @mirrors, "http://ftpmirror.gnu.org/$1";
push @mirrors, "http://ftp.gnu.org/pub/gnu/$1";