aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 10:47:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 10:47:32 +0000
commit883b5b8191eef2f294e5bf2e7bad810b9bd65493 (patch)
tree9db374f440c736efcbcde24d2b8256eb241b0d99
parentdeb4c31da4401fd8007ee49fb37082aa61e2856e (diff)
downloadupstream-883b5b8191eef2f294e5bf2e7bad810b9bd65493.tar.gz
upstream-883b5b8191eef2f294e5bf2e7bad810b9bd65493.tar.bz2
upstream-883b5b8191eef2f294e5bf2e7bad810b9bd65493.zip
build: add @APACHE download facility
The Apache Software Foundation offers diverse download mirros. For packaging Apache software a new alias @APACHE is defined. Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de> SVN-Revision: 48270
-rw-r--r--include/download.mk2
-rwxr-xr-xscripts/download.pl6
2 files changed, 7 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 8a1205df00..ca5eee4e02 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -13,7 +13,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
define dl_method
$(strip \
$(if $(2),$(2), \
- $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+ $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \
diff --git a/scripts/download.pl b/scripts/download.pl
index 9d1fe4755a..25c73fbeb5 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
@@ -176,6 +176,12 @@ foreach my $mirror (@ARGV) {
for (1 .. 5) {
push @mirrors, "http://downloads.sourceforge.net/$1";
}
+ } elsif ($mirror =~ /^\@APACHE\/(.+)$/) {
+ push @mirrors, "http://ftp.tudelft.nl/apache/$1";
+ push @mirrors, "http://apache.openmirror.de/$1";
+ push @mirrors, "http://mirrors.ocf.berkeley.edu/apache/$1";
+ push @mirrors, "http://mirror.cc.columbia.edu/pub/software/apache/$1";
+ push @mirrors, "http://ftp.jaist.ac.jp/pub/apache/$1";
} elsif ($mirror =~ /^\@GNU\/(.+)$/) {
push @mirrors, "http://ftpmirror.gnu.org/$1";
push @mirrors, "http://ftp.gnu.org/pub/gnu/$1";