aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-images.in2
-rw-r--r--target/linux/x86/image/Makefile6
2 files changed, 3 insertions, 5 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 95752f737a..55aff7d087 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -242,7 +242,7 @@ menu "Target Images"
config TARGET_IMAGES_GZIP
bool "GZip images"
- depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
+ depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS || TARGET_x86
default y
comment "Image Options"
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index ca5d0123c7..d3005d79c3 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -153,11 +153,9 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
define Image/Build/gzip/ext4
$(call Image/Build/gzip,ext4)
endef
- ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
- define Image/Build/gzip/squashfs
+ define Image/Build/gzip/squashfs
$(call Image/Build/gzip,squashfs)
- endef
- endif
+ endef
endif
define Image/BuildKernel