aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-27 15:18:22 +0200
committerFelix Fietkau <nbd@nbd.name>2017-07-06 11:30:33 +0200
commit7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa (patch)
treed2efedef80b6b28a65139f1cd6d41aed380a6780
parent6b127d86390f85e92e59f3dba04fa585efb3b2c5 (diff)
downloadupstream-7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa.tar.gz
upstream-7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa.tar.bz2
upstream-7887a46f4533e4ba6de0f24ea9a9fc838d0ea7aa.zip
build: enable gzipping of images on x86 even if ext4 is disabled
There is lots of padding between the boot partition and the rootfs, so gzipping is helpful here Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--config/Config-images.in2
-rw-r--r--target/linux/x86/image/Makefile6
2 files changed, 3 insertions, 5 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 95752f737a..55aff7d087 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -242,7 +242,7 @@ menu "Target Images"
config TARGET_IMAGES_GZIP
bool "GZip images"
- depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
+ depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS || TARGET_x86
default y
comment "Image Options"
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index ca5d0123c7..d3005d79c3 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -153,11 +153,9 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
define Image/Build/gzip/ext4
$(call Image/Build/gzip,ext4)
endef
- ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
- define Image/Build/gzip/squashfs
+ define Image/Build/gzip/squashfs
$(call Image/Build/gzip,squashfs)
- endef
- endif
+ endef
endif
define Image/BuildKernel