aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorThomas Nixon <tom@tomn.co.uk>2021-01-09 22:04:48 +0000
committerPaul Spooren <mail@aparcar.org>2021-01-10 21:40:23 -1000
commitc625c821d1a3825a9fd939cb132aee8c2e713169 (patch)
treef0c582cd8e43633a24703c36310f1db2aa39194f /tools
parentb1150de9e437d23bb8629dfb2cba06bdcdbb2e7b (diff)
downloadupstream-c625c821d1a3825a9fd939cb132aee8c2e713169.tar.gz
upstream-c625c821d1a3825a9fd939cb132aee8c2e713169.tar.bz2
upstream-c625c821d1a3825a9fd939cb132aee8c2e713169.zip
tools/ccache: find libzstd using rpath
Previously, ccache would end up using the system libzstd, which is not supposed to be a build requirement. Signed-off-by: Thomas Nixon <tom@tomn.co.uk>
Diffstat (limited to 'tools')
-rw-r--r--tools/ccache/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index e016e0beb3..ff0204ae19 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -21,7 +21,10 @@ include $(INCLUDE_DIR)/cmake.mk
CMAKE_HOST_OPTIONS += \
-DCMAKE_C_COMPILER_LAUNCHER="" \
- -DCMAKE_CXX_COMPILER_LAUNCHER=""
+ -DCMAKE_CXX_COMPILER_LAUNCHER="" \
+ -DCMAKE_SKIP_RPATH=FALSE \
+ -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+
define Host/Install/ccache
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/