aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libuuid
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-01-13 05:21:50 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-01-13 05:21:50 +0000
commit5cc66964c130ec0521b54325e7050760707773aa (patch)
treed0fbbf9ea82ceb02b5330f6c5c47a22cc28bc169 /tools/libuuid
parent75d5301b3e09de8fa117b8f64e2ef3520da2fa03 (diff)
downloadupstream-5cc66964c130ec0521b54325e7050760707773aa.tar.gz
upstream-5cc66964c130ec0521b54325e7050760707773aa.tar.bz2
upstream-5cc66964c130ec0521b54325e7050760707773aa.zip
Fix libuuid header location and reenable building of mkfs.ubifs
SVN-Revision: 19113
Diffstat (limited to 'tools/libuuid')
-rw-r--r--tools/libuuid/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/libuuid/Makefile b/tools/libuuid/Makefile
index 672591fe1d..4e6602e488 100644
--- a/tools/libuuid/Makefile
+++ b/tools/libuuid/Makefile
@@ -36,13 +36,13 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include}
- $(CP) $(HOST_BUILD_DIR)/lib/uuid/uuid.h $(STAGING_DIR_HOST)/include/
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/uuid}
+ $(CP) $(HOST_BUILD_DIR)/lib/uuid/uuid.h $(STAGING_DIR_HOST)/include/uuid/
$(CP) $(HOST_BUILD_DIR)/lib/uuid/libuuid.{so*,a} $(STAGING_DIR_HOST)/lib/
endef
define Host/Clean
- rm -f $(STAGING_DIR_HOST)/include/uuid.h
+ rm -f $(STAGING_DIR_HOST)/include/uuid/uuid.h
rm -f $(STAGING_DIR_HOST)/lib/uuid/libuuid.{so*,a}
$(call Host/Clean/Default)
endef