aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/libuuid/Makefile6
-rw-r--r--tools/mtd-utils/Makefile8
2 files changed, 9 insertions, 5 deletions
diff --git a/tools/libuuid/Makefile b/tools/libuuid/Makefile
index 672591fe1d..4e6602e488 100644
--- a/tools/libuuid/Makefile
+++ b/tools/libuuid/Makefile
@@ -36,13 +36,13 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include}
- $(CP) $(HOST_BUILD_DIR)/lib/uuid/uuid.h $(STAGING_DIR_HOST)/include/
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/uuid}
+ $(CP) $(HOST_BUILD_DIR)/lib/uuid/uuid.h $(STAGING_DIR_HOST)/include/uuid/
$(CP) $(HOST_BUILD_DIR)/lib/uuid/libuuid.{so*,a} $(STAGING_DIR_HOST)/lib/
endef
define Host/Clean
- rm -f $(STAGING_DIR_HOST)/include/uuid.h
+ rm -f $(STAGING_DIR_HOST)/include/uuid/uuid.h
rm -f $(STAGING_DIR_HOST)/lib/uuid/libuuid.{so*,a}
$(call Host/Clean/Default)
endef
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index 69b7b159d6..8938614e76 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -21,7 +21,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR)
+CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib
ifneq ($(HOST_OS),Linux)
CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h
endif
@@ -39,17 +39,21 @@ define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/ubi-utils \
$(MTD_MAKEOPTS) \
TARGETS=ubinize
+ $(MAKE) -C $(HOST_BUILD_DIR)/mkfs.ubifs \
+ $(MTD_MAKEOPTS) \
+ BUILDDIR="$(HOST_BUILD_DIR)/mkfs.ubifs"
endef
define Host/Install
$(CP) \
$(HOST_BUILD_DIR)/mkfs.jffs2 \
+ $(HOST_BUILD_DIR)/mkfs.ubifs/mkfs.ubifs \
$(HOST_BUILD_DIR)/ubinize \
$(STAGING_DIR_HOST)/bin/
endef
define Host/Clean
- rm -f $(STAGING_DIR_HOST)/bin/{mkfs.jffs2,ubinize}
+ rm -f $(STAGING_DIR_HOST)/bin/{mkfs.jffs2,mkfs.ubifs,ubinize}
endef
$(eval $(call HostBuild))